Rails 1.1.4 Should Run Unmodified in JRuby

4 07 2006

Charles Nutter: “Now, with the release of 1.1.4, the following will all work out-of-the-box with JRuby 0.9.0 (currently in RC status):”

gem install rails --include-dependencies

Check

# and use --no-rdoc for now...it's too slow

Check, even though it insisted on building documentation and yes, it was slow, but it finished eventually.

rails ~/myapp
lib/ruby/gems/1.8/gems/rails-1.1.4/bin/../lib/rails_generator/options.rb:33:
        in `method_missing': undefined method `write_inheritable_attribute' for
Rails::Generator::Base:Class (NoMethodError)
        from lib/ruby/gems/1.8/gems/rails-1.1.4/bin/../lib/rails_generator/options.rb:33:
        in `default_options'

OK, we’re almost there, but not quite there yet:

Keep in mind that we don’t officially “support” Rails just yet; there’s more work to do. We are, however, another leap beyond the JavaOne demo, and at this rate things are looking very good for an end-of-Summer JRuby 1.0.

I’m not sweating over it. Take your time and make it really rock, folks.

Advertisements

Actions

Information

One response

1 05 2007
Carl Graff

Hi Charles,

I get this same error message when attempting to create a new rails application in Aptana RadRails using rails 1.2.3. I don’t think they’re using JRuby. Any clue? – I think it is supposed to be defined in activesupport.

Thanks,
Carl

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s




%d bloggers like this: